update.php(v.1.186) [4.7.0 ~ 4.7.3 専用] 日本語 06/07/21版

※ 06/05/09 に公開したものには、アップデートできないバグがありました。 修正して再リリースしましたので、再度ダウンロードしてください。
update.php は、Drupal コア(本体)のアップグレードの際だけでなく、拡張モジュールのアップデートにも必要になるものです。 ここでは、Drupal 4.7.0, 4.7.1, 4.7.2, 4.7.3 に付属の update.php を邦訳したものを配布しています。
update.php は、Drupal のバージョンに依存しますので、必ずご利用中のバージョンに合ったものを使用してください。 ご利用中のバージョンの確認は、インストールしたディレクトリにある "update.php" をエディタなどで開き、先頭付近にある以下の行の "~~~" 部分をご覧下さい。

// $Id: update.php,v 1.186 2006/04/20 16:34:31 killes Exp $
                     ~~~~~

また、アップデート作業は、データベース破損の危険性が非常に高いので、必ずデータベースのバックアップを取ったのちに行ってください。
なお、万が一、ここで配布しているファイルを使用した結果、データの破損等が起こりましても、当サイトおよび関係者は一切の責を負いかねますので、あらかじめご了承ください。

使用方法

ファイルを解凍後、"update.php" をインストールディレクトリにある同名ファイルに上書きしてください。

履歴

  • 2006/05/09 -- 初版リリース
  • 2006/07/21 -- case 'Update' を 'アップデート' に修正